Network Degraded in the Zürich Datacenter

Incident Report for Statuspage Netrics Zürich AG

Resolved

Everything seems to be stable. We're closing this incident.
Posted Aug 18, 2026 - 15:39 CEST

Monitoring

All services have been restored, we are still keeping an eye on everything for the next few hours.
Posted Aug 18, 2026 - 11:25 CEST

Update

The issue affecting our core routers has been mostly resolved, and network performance is improving.

Our engineering team is continuing to test and troubleshoot individual systems to ensure all services are operating normally. The root cause remains under investigation.

We will provide a further update as additional information becomes available.
Posted Aug 18, 2026 - 10:57 CEST

Investigating

We are investigating network degradation affecting services hosted in our Zürich datacenter. Customers may experience increased latency, intermittent connectivity issues, or reduced service performance.

Our engineering team is actively working to identify the root cause and restore normal network performance. We will provide another update as soon as more information is available.
Posted Aug 18, 2026 - 10:05 CEST
This incident affected: Backbone Network Service and Datacenter Service Zürich.